Back to overview
DNS failure
Jun 25 at 03:59am HDT
Affected services
lyrisot.tech
Resolved
Jun 25 at 09:31am HDT
Domain is back up
Affected services
Created
Jun 25 at 03:59am HDT
Domain is currently unavailable for all users. Our team is currently investigating the root cause.
Affected services